HEAT TRANSFER AND THERMOSTRUCTURAL ANALYSIS
OF A CYLINDER

Pomnt Load [1000 kN ]

Temperature «——
[373 K]

F 3

0.26

Convection =«
[100 W/m?K ] 4

2.8

V77777777 Th _
Heat Flux .—/ Thickness : 5 mm
[10 kW/m? |

All dimensions are in meter

An aluminium cylinder of 4m height, 5Smm thickness and 1m radius is considered for this
tutorial. The outer surface of the cylinder is adiabatically sealed and a portion of the cylinder 26
cm at a height 2.8 m is exposed to the sorrounding which has a convective coefficient of 100 W/m?
K at 300 K. A constant heat flux 10 kW/m? is acting at the bottom, whereas the top edge of the
cylinder is maintained at 373 K.

A structural load of 1000 kN is acting at the top edge of the cylinder and the bottom of the
cylinder is assumed to be fixed. The objective of this analysis is to find the maximum stress due
to the thermal environment along with the mechanical loads.



PROCEDURE
1. Create Keypoints
Command: POINT, ADD

Menu : Geometry > Keypoint-> Create > ADD

POIMT, ADD
Point Data |0:0:0
Parameters:

Similarly create key points at (0:4:0) and (1:0:0)

At the end of the operation your screen should look like this.
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2. Create Cylindrical Surface

Command: SURFACE, CYLAXIS

Menu : Geometry >Surface-> Create —->Cylaxis



Axis

Radius

Parameters:

SURFACE, CYLAXIS
P1/P2 I3

P3 I3

At the end of the operation your screen should look like this.
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3. Generate mesh

Command: MESH, QUAD

Menu : Mesh->MeshGen->Quad

Parameters:

MESH, QUAD
Surface 1[0] [y
Element size |0.130908 [y
Method Mapped j
Type 4-Mode j
Divisions [y
Bias [.\‘;




Element size can be entered manually or by clicking two points on the geometry edge. Then click
on the 'Divisions' command box, so that node divisions will be displayed on the geometry. The
element subdivisions can be increased or decreased by left clicking or right clicking respectively.

At the end of the operation your screen should look like this.
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4. Apply Material Property

Command: MATERIAL, HTISOTROPIC

Menu . Property->Material - Thermal - Isotropic
MATERIAL, EDIT
Elements 1T1410[0] ls
Thermal Conductivity |237 E
Density 2800 [
Specific Heat 900 E=d
Label

Parameters:

5. Apply Thickness

Command: THICKNESS, ADD

Menu . Property->Physical > Thickness



THICKMESS, EDIT

Elements | 1T1410[0] [x
Thickness |0.005 [
Label

Parameters:

6. Apply Convective Boundary Condition
Command: HTCONVEC, ADD
Menu : Load/BC- Thermal->Convection

HTCOMNVEC, EDIT

Entity Type Face j
Entity Face B(F1)9(F1)38(F1)20(F1)68(F1 [}
Film Coefficient 100 £
Ambient Temperature 300 B
Label

Parameters:

The selected face is look like below
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7. Apply Heat Flux Boundary Condition
Command: HTFLUIX, ADD
Menu . Load/BC->Thermal->Heat flux



HTFLUX, EDIT
Entity Type Edge j

Entity Edge |30T1410B30(D2)[0] Iy
Flux Rate |10 x|
LCS 0 [y

Parameters: =
The defined edge is look like this,
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8. Apply Temperature Boundary Condition
Command: HTTEMP, ADD
Menu . Load/BC->Thermal->Temperature

HTTEMP, EDIT
Modes 1T1427831[0]
Temperature |373

Label
Parameters:

The defined nodes is look like this,




10.
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Set Analysis Type
Command: ANTYPE, SET
Menu . Analysis-> Analysis Type

ANTYPE, ADD

Analysis Types |HT Steadystate

Parameters:

Save the project
Menu: File > Save




i Click H
11. Activate solver ick Here
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12. Perform Post Processing

i) Graph plots for displacement/ velocity/ acceleration
Command: POST, CONTOUR

Menu : Post->Contour

Post, Contour

ltem Temperature b
Restrict To =3
Contour Type Band j
No of contours Dﬁ
Decimal Places Zﬁ

Iv Element Outline

[ Draw Border

I Highlight Maximum
I Highlight Minimum

Parameters Colour-Label ]

At the end of the operation your screen should look like this.
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I™ Draw Border

To perform thermo-structural analysis, the same model with load of 1000 kN at top edge of

I™ Highlight Maximum

Pest, Contour

Item Temperature -]
Restrict To — &
Contour Type [Band
No of contours 98]
Decimal Places 25 r
[¥ Element Outline
. X

Max:373 Min: 301.047

the cylinder and the procedure for this analysis is detailed below.
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After meshing follow below steps,
1. Apply Boundary Condition

Command: DISPBC, ADD
Menu . Load/BC-> Structural-> Displacement

DISPEC, ADD
MNodes |43T2838B43[0]
DispBC |0/0/0/0/0/0

& ([ |&

LCS 0
Label

Parameter:

At the end of the operation your screen look like this,
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2. Apply Material Property
Command: MATERIAL, ISOTROPIC

Menu . Property->Material - Structural - Isotropic

=




MATERIAL, ISOTROPIC

Elements ALL
Young's Modulus | 7T0EQ9
MNu 0.3
Density 2800
Alpha

Label

Parameter:

Thickness is same as applied in heat transfer analysis

3. Apply Point load
Command: POINTLOAD, ADD

Menu : LoadBC - Structural >Point load
POINTLOAD, EDIT

Nodes 1T1427831[0] [
Magnitude |-1000e+3 [
Component |FY j
LCS [3
Label

Parameter:

The node for point load is at the top end

4. Apply Thermal load
Command: THERMAL, ADD

Menu . LoadBC ->Structural ->Thermal load
THERMAL, ADD
Nodes ALL
Temperature Source  |File
File name EA\Thermostructural\cylinder-HT_Tm_4m.OUT
Reference temperature |0
Label
Parameter:

Select the *.out file from heat transfer analysis file location.

5. Set Analysis type
Command: ANTYPE, SET

Menu . Analysis-> Analysis Type
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ANTYPE, ADD

Analysis Types |Static

Parameter :

After that follow steps from 10 and 11 from heat transfer analysis

1. Perform Post processing

Command: POST, CONTOUR

Menu

Parameter:

Post-> Contour

[tem
Component:Disp...
[~ On Deformed

Post, Contour

|Displacement

[Tv

Lelle

At the end of the operation your screen should look like this.
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To find stress contour in y direction,
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FREE VIBRATION ANALYSIS OF A CYLINDER

Thickness : 3mm

All dimensions are in meter

An aluminium cylinder of radius 2m and height 4m is constrained at the bottom through 24 bolted
joints. The thickness of the cylinder is 3mm. A mass of 500 kg is lumped at a height of 5m from
the cylinder top surface. The mass is connected with the top of the cylinder through 24 bolted
joints. Initially a free vibration analysis is performed to estimate the natural frequencies and mode
shapes of the system.

A 1g steady state lateral base excitation is applied at the bottom of the cylinder and the
response at the mass is estimated. This is done by performing a frequency response base excitation
analysis. The lateral base excitation is applied to the cylinder through a heavy inertial mass 50
times greater than the system mass. The inertial mass is connected to the cylinder bottom portion
through 24 number of rigid links. 2% critical damping is assumed for all the modes.



PROCEDURE
2. Create Key points
Command: POINT, ADD

Menu : Geometry > Keypoint-> Create - ADD

POINT, ADD

Point Data |0:0:0
Parameters:

Similarly create key points at (0:4:0) and (2:0:0)

At the end of the operation your screen should look like this.
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3. Create Cylindrical Surface

Command :SURFACE, CYLAXIS

Menu : Geometry —>Surface> Create —->Cylaxis

SURFACE, CYLAXIS
Axis  |P1/P3 Ly

Radius |P2 I3
Parameters :

At the end of the operation your screen should look like this.
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4. Generate mesh

Command :MESH, QUAD

Menu : Mesh->MeshGen->Quad
MESH, QUAD
Surface 100] [y
Element size |0.237685 [y
Method ~  Mapped -
Type 4-Mode j
Divisions | 51(D20]*T2/51(D4)[0]72 Iy
Bias R

Parameters :

Element size can be entered manually or by clicking two points on the geometry edge. Then click
on the 'Divisions' command box, so that node divisions will be displayed on the geometry. The
element subdivisions can be increased or decreased by left clicking or right clicking respectively.

At the end of the operation your screen should look like this.



File Edit View Geometry Mesh Load/BC Property Anabysic Post Others Windows Help
odé d g BOoNyL yE e 0 0EM &

= Model| Main] Show| Lag Colour| settings|
J
. || objects @ Default
|| Labels ¢ Material v@ggﬁgﬁ%
o || Bockground | g
- i
@ || 'Shacing Dimension
& || ColourList ¢ Compenent
Y
4]
s
=
B
“ml
2
B o, [store.
»
MESH, QUAD
|
Suface  [110] b
Element size |0.237683 [FY v
Method | Mapped -
Type 4-Node Rl @ =
Divisions [
B [y

5. Apply Material Property
Command: MATERIAL, ISOTROPIC

Menu . Property->Material - Structural - Isotropic

MATERIAL, ISOTROPIC

Elements ALL %
Young's Modulus | 70e09 =1
Nu 0.3 £
Density 2800 B
Alpha B
Label

Parameters:

6. Apply Thickness

Command: THICKNESS, ADD
Menu . Property->Physical > Thickness

THICKMESS, ADD
Elements |18T34/32T68/86T102/120T136/134T1701 R
Thickness |0.003 =4
Label

Parameters:

7. Create Rigid link
Command: RLINK, ADD
Menu . Load/BC->Structural>Rigid link



RLINK, ADD
Master Nede |2522[0] ls
Slave Modes | 18T24338105(0] Iy
Master DOF | Any j
Slave DOFs | 123436 =
LCS ls
Label

I.  Parameters :
Create node at 0:9:0 by (Mesh >Node >Create> Add) and it is taken as Master node
remaining nodes at top edge is taken as slave nodes (Slave nodes should be 24. equally
spaced between 72 nodes at bottom).

At the end of the operation your screen should look like this,
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8. Apply Boundary Condition
Command: DISPBC, ADD
Menu . Load/BC-> Structural-> Displacement



Parameters:

Translation
™ Ux IT
DISPBC, ADD Fufo
¥ Uz |D_
MNodes |2523[0]
Retation
DispBC |/0/0/0/0/0 = <_p ~
Lcs |0 3 weyfo
¥ Rz ]07

Label

Apply
Cancel

™ Selectall

Apply DISPBC at bottom edge nodes corresponding to 24 rigid links

9. Set Mass Data

i. Command: ELEMENT, ADD

Menu Mesh-> Element - Create > Add
| |
ELEMENT, ADD Spring
Dimension |0 j
1 = 4—-£ccept Cancel
Parameters:

Node id at location 0:9:0.
ii. Command: MASS, ADD

Menu . Property-> Physical> Mass

MASS, ADD
Elements |2443(0]
M 500
MY 500
Mz 500
XX 0
IvY
izz
XY

S| el e e e

IXZ
YZ
Label

Parameters:

Mass of 500 is defined at top node id 0:9:0

10. Set Analysis Type

Command :ANTYPE,SET

Menu . Analysis-> Analysis Type
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AMTYPE, EDIT

Analysis Types |Free vibration ﬂ
Parameters :

11. Save the project
Menu: File > Save

12. Activate solver Click Here
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13. Perform Post Processing

I.  Tocheck natural frequencies

Command: POST, VIEWRESULT

Menu . Post >Table View

Post, TableView

[tem |Frequency j
Parameters:
WMode Frequency(Hz) |2
| 1 23.4446
| 2 23.4446
| 3 23.8027
| 4 23.8027
| 5 25.203
| B 23.203
| 7 25.791%
| 8 25.791%
| 9 28,1618
| 10 28.9817 —
| 11 28.9817
| 12 29.5078
| 13 29.5117

| 14 30,4276 =
4 N
Close |



FREQUENCY RESPONSE ANALYSIS OF A BASE EXCITED
CYLINDER

Thickness : 3mm

All dimensions are in meter

An aluminium cylinder of radius 2m and height 4m is constrained at the bottom through 24 bolted
joints. The thickness of the cylinder is 3mm. A mass of 500 kg is lumped at a height of 5m from
the cylinder top surface. The mass is connected with the top of the cylinder through 24 bolted
joints. Initially a free vibration analysis is performed to estimate the natural frequencies and mode
shapes of the system.

A 1g steady state lateral base excitation is applied at the bottom of the cylinder and the
response at the mass is estimated. This is done by performing a frequency response base excitation
analysis. The lateral base excitation is applied to the cylinder through a heavy inertial mass 50
times greater than the system mass. The inertial mass is connected to the cylinder bottom portion
through 24 number of rigid links. 2% critical damping is assumed for all the modes.



PROCEDURE
14. Create Key points
Command: POINT, ADD

Menu : Geometry > Keypoint-> Create > ADD

POINT, ADD

Point Data |0:0:0
Parameters:

Similarly create key points at (0:4:0) and (2:0:0)

At the end of the operation your screen should look like this.
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15. Create Cylindrical Surface

Command :SURFACE, CYLAXIS

Menu . Geometry —>Surface> Create >Cylaxis
SURFACE, CYLAXIS
Axis  |P1/P3 [z
Radius |P2 [s

Parameters :



At the end of the operation your screen should look like this.
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16. Generate mesh

Command :MESH, QUAD

Menu : Mesh->MeshGen->Quad
MESH, QUAD
Surface 1001 [y
Element size  0.237685 [y
Method Mapped ~
Type 4-Mode j
Divisions | 51(D2)[0]72/51(D4)[0]*72 [
Bias [y

Parameters :

Element size can be entered manually or by clicking two points on the geometry edge. Then click
on the 'Divisions' command box, so that node divisions will be displayed on the geometry. The
element subdivisions can be increased or decreased by left clicking or right clicking respectively.

At the end of the operation your screen should look like this.
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17. Apply Boundary Condition
Command: DISPBC, ADD

Menu

Parameters:

Apply DISPBC at

Load/BC-> Structural->Displacement

DISPEC, ADD
Modes |2523[0]
DispBC |/0/0/0/0/0 =
Lcs |0 ls

Label

location 0:0:0

18. Apply Material Property

Command: MATERIAL, ISOTROPIC

Menu

Parameters:

MATERIAL, ISOTROPIC

Elements ALL %
Young's Modulus | 70e09 Bl
Mu 0.3 =1
Density 2800 B
Alpha =1
Label

Translation

Mux o
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Apply
Cancel

™ Selectall

Rotation
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Property->Material - Structural - Isotropic



19. Apply Thickness

Command: THICKNESS, ADD
Menu . Property->Physical > Thickness

THICKMESS, ADD
Elements |18T34/32T68/86T102/120T136/134T1701 R
Thickness |0.003 =4
Label

Parameters:

20. Create Rigidlink
Command :RLINK,ADD

Menu . Load/BC-> Structural>Rigidlink
RLINK, ADD
Master Mode |2522[0] ls
Slave Modes | 18T24338105[0] Iz
Master DOF | Any j
Slave DOFs | 123456 =l
LCS Iz
.- Label
Il.  Parameters:
RLIMK, ADD
Master Node |2523[0] [
Slave Nodes |35T2450B105[0] le
Master DOF | Any j
Slave DOFs 123456 x|
LCS [

Lakel
iii. Parameters :

Create node at 0:0:0 by (Mesh >Node >Create> Add) and it is taken as Master node
remaining nodes at bottom edge is taken as slave nodes (Slave nodes should be 24. equally
spaced between 72 nodes at bottom). Similarly create node at a height of 0:9:0 and create

rigid links similar to the bottom edge.

At the end of the operation your screen should look like this.
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21. Set Mass Data
iii. Command: ELEMENT, ADD
Menu . Mesh-> Element - Create > Add

B Element Type s
ELEMENT, ADD Spring
Noses  [25220 B
Dimension |0 ﬂ
Type E Qancell

Parameters:

Node id at location 0:9:0. Similarly create mass element at 0:0:0
iv. ~ Command: MASS, ADD

Menu . Property—> Physical> Mass
Elements [2443[0] : M Elements | 2450[0] : M
Mx [s00 = omx 50000 =
My [s00 =) My [s0000 =
Mz [s0 =) Mz [s0000 =
XX [o E IXX o E
v [o = w o =
1zz [o =5 oz o =
Xy Io % Xy o =
Xz o @ e o =
v o =B o o =

Parameters: | e |

Mass of 500 is defined at top node and mass of 50000 is defined at bottom mass

location.
22. Set Base Excitation Data

Command: BASEEXCITATION, ADD

Menu : Load/BC->Structural-=>Base Excitation



Parameters:

At the end of the operation your screen should look like this.

BASEEXCITATION, ADD
Modes 2323[0]
Magnitude | 9.81
Component |UX
LCS

abel
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23. Create Damping Data

Command: DAMPING, ADD

Menu

Parameters:

Analysis ->Damping

DAMPING, ADD
Damping model |Modal Damping j
Damping Factors |5/0.02/100/0.02

| Add Row

&
}
Freauency Damping Factor |
5 002
100 002
=«

Insert Row

Delete Row

Paste

From file....

Cancel

el EEE R

Apply



24. Set Analysis Type

Command :ANTYPE,SET
Menu . Analysis>Analysis Type

Parameters : ANTYPE,SET

Analysis Type Frequency Response —

25. Set Frequency Response General Data

Command: FREQRESGEN, ADD

Menu . Analysis > Frequency Response - General
FREQRESPGEN, ADD

Response Extraction |Auto j
Start Frequency 5
End Frequency 40
Finer Increment 0.1
Coarser Increment |1
MNumber of modes |20
Mass type Lurnped j
Stress OQutput NO j
Nodes ALL [3

Parameters:

Note :

In the node list the node IDs of the nodes at which the response to be extracted is specified

26. Save the project
Menu: File > Save



27. Activate solver Click Here
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28. Perform Post Processing

I.  Graph plots for displacement/ velocity/ acceleration

Command: POST, HISTORYPLOT

Menu . Post>History Plot
Post, HistoryPlot
[termn Acceleration j
CompenentAcce.. |TX j
Nodes 2522[0] ls
Complex as Medulus j
Parameters:

Select the top mass lumping node. At the end of the operation your screen should look like this.
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Il.  To check natural frequencies

Command: POST, VIEWRESULT

Menu . Post >Table View

Post, TableView

Itern |Frequency j
Parameters:
ode Frequency(Hz) |2
il 1 23.427
| 2 23.427
il 3 237916
| 4 23.7916
i 5 251774
il 6 251774
| T 25.7859
i H] 25.7859
il ] 28,1617
| 10 28.9362 —
i M 28.9362
il 12 204729
| 13 20.473
| 14 30.4186| _
4 ol

Close




